GT 2L turbo 93 EJ20, ECU en sécurité, code 12

faisceau électrique, câblage, ...

Modérateurs : Moderateurs, Comité

Floumy
Webclubiste
Messages : 20
Inscription : lun. août 21, 2017 16:59
Véhicule : Nova Sterling

GT 2L turbo 93 EJ20, ECU en sécurité, code 12

Messagepar Floumy » mer. sept. 18, 2019 08:32

Bonjour,
je possède un moteur 2L turbo, monté sur un châssis et boite cox.
j'ai refait le faisceau car il était en partie fondu lorsque j'avais récupéré le véhicule il y a 2 ans.

Lors d'une récente sortie, la durite d'air de l'échangeur s'est arrachée, mais avant de trouver la panne, j'ai insisté sur le démarreur pour finalement finir sur un plateau.

De retour dans mon garage, j'ai remis la durite. Mais impossible de démarrer:
-compressions bonnes
-allumage ok (j'ai bien une étincelle aux bougies)
-pompe essence qui tourne et retour d'essence au réservoir OK
-pas d'essence aux injecteurs.
J'en conclu que l'ECU s'est mis en sécurité et n’envoie pas de signal pour pulvériser l'essence.

j'ai fait une lecture de code erreur, qui me donne le code 12: Starter SWITCH / CLUTCH SWITCH, N POSITION

Comment fonctionnent ces switchs?
est-ce que si je mets les connecteurs directement à la masse moteur, cela pourra corriger le code erreur.
et quel brain/fils dois-je mettre à la masse? (j'ai toutes les docs)

si vous avez d'autre idées, elles sont bienvenues.

Avatar de l’utilisateur
StephWRX
Administrateur
Administrateur
Messages : 10990
Inscription : dim. oct. 06, 2002 22:52
Véhicule : WRX 2001 Dark Blue RWD
Localisation : Geneve - Suisse

Re: GT 2L turbo 93 EJ20, ECU en sécurité, code 12

Messagepar StephWRX » mer. sept. 18, 2019 13:44

Il y a un capteur point mort sur les boites sub et il est très important. Je sais pas si tu peux l'avoir sur ta boite Cox...

Mais je pense pas qu'il empêche de démarrer... il affecte plus l'allumage...

Floumy
Webclubiste
Messages : 20
Inscription : lun. août 21, 2017 16:59
Véhicule : Nova Sterling

Re: GT 2L turbo 93 EJ20, ECU en sécurité, code 12

Messagepar Floumy » mer. sept. 18, 2019 17:12

Salut StephWRX,
non je n'ai pas de capteur de point mort sur ma boite, le seul fil que j'ai branché est le contacteur de marche arrière pour allumer les feux de recul.
pour le reste, c'est un vrai jeu de piste:.
Ce dont tu me parles serait le Inhibitor Switch (Wiring diagram 6-3 [D602] page 6) connecteur B1 -> mais je ne sais pas où le prendre sur mon ECU (pin 4 du connecteur B2)
ou alors le Transmition cord (Neutral Position Switch) (Wiring diafram 6-3 [D602] page 7) qui se prendrait sur le pin11 et 22 du connecteur ECU B43.
pour ce dernier, est ce que le fait de le mettre directement à la masse peut suffire ?

Floumy
Webclubiste
Messages : 20
Inscription : lun. août 21, 2017 16:59
Véhicule : Nova Sterling

Re: GT 2L turbo 93 EJ20, ECU en sécurité, code 12

Messagepar Floumy » sam. sept. 21, 2019 19:33

1/2 journée de plus à tester les faisceau 1 par 1.
Et toujours pas démarré. Le démarreur lance la moteur, j'ai de l'essence et l'étincelle aux bougies, mais le moteur ne tourne pas. Et toujours de code erreur 12...

Floumy
Webclubiste
Messages : 20
Inscription : lun. août 21, 2017 16:59
Véhicule : Nova Sterling

Re: GT 2L turbo 93 EJ20, ECU en sécurité, code 12

Messagepar Floumy » jeu. nov. 07, 2019 13:54

Rebonjour, après avoir testé à l'ohmmètre un bon paquet de faisceau, toujours rien, mais le diagnostique se précise:
Capteur PMH et AAC mesurés à 2000 ohm.
1 Bobine sur les 4 est morte (j'ai passé commande)
étincelles au 3 autres bobines.
le code erreur 12 est " normal" car le faisceau a été adapté, et donc cette entrée n'est plus connecté à l'ECU, ce qui ne l’empêchait pas de fonctionner avant.

une nouvelle piste,
-pas d'essence aux injecteurs, mais j'ai bien le 12V sur chaque connecteur.
Je vérifie les masses pour le moment.

Si vous avez des idées...

Floumy
Webclubiste
Messages : 20
Inscription : lun. août 21, 2017 16:59
Véhicule : Nova Sterling

Re: GT 2L turbo 93 EJ20, ECU en sécurité, code 12

Messagepar Floumy » jeu. nov. 14, 2019 12:55

Panne résolue,
J'ai remonté les Bobines neuves, le moteur a pris au premier coup de démarreur.

Moralité:
LORSQUE L'ON TESTE L'ALLUMAGE, ON TESTE TOUTES LES BOUGIES !!!
mon erreur est que j'avais testé uniquement le cylindre n° 1, sur lequel ma bobine est bonne.
en fait il n'y avait pas d'étincelle sur la bobine n°2,et très faible sur les n°3 et 4.

visiblement, L'ECU coupe la mise à la masse des injecteurs si le signal des bobines d'allumage est trop faible ou inexistant.

Avatar de l’utilisateur
Steph57
Grand Webclubber
Messages : 381
Inscription : mar. sept. 27, 2016 21:41

Re: GT 2L turbo 93 EJ20, ECU en sécurité, code 12

Messagepar Steph57 » jeu. nov. 14, 2019 13:04

Bonne nouvelle tout ça

Avatar de l’utilisateur
YH
Vétéran du webclub
Messages : 1633
Inscription : lun. mars 29, 2004 11:09

Re: GT 2L turbo 93 EJ20, ECU en sécurité, code 12

Messagepar YH » jeu. nov. 14, 2019 13:55

bonne nouvelle mais surtout merci de ton retex avec à la clé l'explication de l'origine du défaut et la solution pour s'en prémunir !

Assez piégeant le test de l'allumage :yes:

Cela pourra être utile à d'autres ici ;-)


Revenir vers « Electricité »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités